Resultaten 1 tot 8 van de 8

Onderwerp: woorden tellen

  1. #1
    Geregistreerd
    Sep 2012
    Berichten
    22

    Standaard woorden tellen

    Beste experten.
    Ik heb een tekst in xl staan en wil daarin tellen hoe vaak een bepaald woord voorkomt. Maar dit lukt niet met aantal als... zie aub voorbeeld hierna.
    kan u helpen? dank u !
    mia

    A2:ik heb een TEKST in xl staan
    A3:en wil tellen hoe vaak in die
    A4:TEKST het woord TEKST
    A5:voorkomt

    formule? =AANTAL.ALS($A$2:$A$5;"tekst")
    0
    dit zou drie moeten zijn…maar hij geeft nul.

  2. # ADS
    Geregistreerd
    Always
    Berichten
    Many
     
  3. #2
    Geregistreerd
    Feb 2007
    Berichten
    3.934

    Standaard

    Code:
    =(LEN(A1&A2&A3&A4)-LEN(SUBSTITUTE(A1&A2&A3&A4;"TEKST";"")))/5
    Willem

    Als er formules als oplossing gegeven wordt, kijk dan altijd even naar:
    Moet ik de ; of de , gebruiken als scheidingsteken?
    Heb ik ook de engelse/ nederlandse versie; anders moeten de formules vertaald worden:
    http://wwwhome.ewi.utwente.nl/~tries...cel/excel.html

  4. #3
    Geregistreerd
    Sep 2012
    Berichten
    22

    Standaard woorden tellen

    sorry dit werkt bij mij niet.
    zie aub bijlage
    (plus, het lijkt me niet zo handig om , als het een lange tekst is, al die vakjes '&' te moeten typen)

    wilt u even in bijlage kijken aub? dank u
    Bijgevoegde Bestanden Bijgevoegde Bestanden

  5. #4
    Geregistreerd
    Apr 2008
    Locatie
    Dordrecht
    Berichten
    5.055

    Standaard

    Willem's formule iets aangepast:

    PHP Code:
    =(LENGTE(A1&A2&A3&A4&A5&A6)-LENGTE(SUBSTITUEREN(HOOFDLETTERS(A1&A2&A3&A4&A5&A6);"TEKST";"")))/
    gr. Eric
    Handige Tools: Smart Indenter & MZ Tools & Formule vertaler

  6. #5
    Geregistreerd
    Apr 2011
    Berichten
    2.068

    Standaard

    Als je een hulpkolom gebruikt, hoef je niet alles aan elkaar te "plakken" maar kan je het gewoon optellen.
    Bijgevoegde Bestanden Bijgevoegde Bestanden

  7. #6
    Geregistreerd
    Jun 2008
    Berichten
    6.473

    Standaard

    of gewoon met:

    PHP Code:
    =COUNTIF(A2:A6;"*"&A1&"*"

  8. #7
    Geregistreerd
    Jul 2008
    Berichten
    291

    Standaard

    Code:
    =SOMPRODUCT((LENGTE(A1:A6)-LENGTE(SUBSTITUEREN(HOOFDLETTERS(A1:A6);"TEKST";"")))/5)

  9. #8
    Geregistreerd
    Nov 2006
    Locatie
    Delft
    Berichten
    7.708

    Standaard

    Een kleine UDF wellicht?
    Code:
    Function TelTekst(Bereik As Range, Woord As String) As Integer
    
        q1 = WorksheetFunction.Transpose(Bereik)
        TelTekst = (Len(UCase(Join(q1))) - (Len(Replace(UCase(Join(q1)), UCase(Woord), "")))) / (Len(Woord))
    
    End Function
    syntax in de sheet:
    PHP Code:
    =TelTekst(A1:A6;"tekst"
    __________________
    Groet, Leo

    Zet je VBA-codes altijd tussen code-tags om je bericht leesbaar te houden.
    Gebruik daarvoor:
    • het knopje # in het berichtvenster dat je krijgt via de 'geavanceerd-knop' onderaan de reacties
    • het toetsenbord en direct intikken als HTML: [code] jouw code [/code]

Gelijkwaardige Onderwerpen

  1. aantal gelijke woorden in cel tellen
    Door pie in forum Afgehandelde vragen
    Reacties: 6
    Laatste Bericht: 21-09-11, 21:17
  2. het zoeken en tellen van woorden.
    Door rhuurman in forum Afgehandelde vragen
    Reacties: 4
    Laatste Bericht: 25-03-11, 17:10
  3. letters en woorden tellen met meerder voorwaarden!
    Door jeroen.m in forum Afgehandelde vragen
    Reacties: 2
    Laatste Bericht: 15-03-11, 15:24
  4. Bepaalde woorden tellen in excel 2003
    Door royp1988 in forum Afgehandelde vragen
    Reacties: 7
    Laatste Bericht: 17-01-11, 09:32
  5. Woorden binnen bereik tellen en weergeven
    Door bumper1983 in forum Afgehandelde vragen
    Reacties: 7
    Laatste Bericht: 28-05-08, 00:53

Forum Rechten

  • Je mag geen nieuwe onderwerpen plaatsen
  • Je mag geen reacties plaatsen
  • Je mag geen bijlagen toevoegen
  • Je mag jouw berichten niet wijzigen
  •