Pagina 1 van de 2 12 LaatsteLaatste
Resultaten 1 tot 10 van de 18

Onderwerp: Lijst alfabetisch sorteren

  1. #1
    Geregistreerd
    Nov 2012
    Berichten
    55

    Standaard Lijst alfabetisch sorteren

    Ik wens een lijst met namen alfabetisch te sorteren.
    Met een hulpkolom wil ik de volgorde bepalen. Echter met lege cellen gaat dit mij niet gemakkelijk af.
    Met een dropdown menu wil ik alle namen alfabetisch rangschikken (A->Z/">" of Z->A/"<").
    -Kolom K geeft het resultaat
    -Bij een 2de kolom wens ik het hyperlink adres te scheiden van de link, is dit mogelijk?
    Bijgevoegde Bestanden Bijgevoegde Bestanden

  2. # ADS
    Geregistreerd
    Always
    Berichten
    Many
     
  3. #2
    Geregistreerd
    Nov 2006
    Locatie
    Delft
    Berichten
    7.361

    Standaard

    PeTh, waarom ben je 't wiel opnieuw aan 't uitvinden? Excel heeft toch een ingebouwde A>Z en Z>A sorteer functionaliteit? Dit kan ik niet volgen...

    En wat bedoel je met het scheiden van een hyperlink adres van een llink? Wil je dan een kaal mail-adres zien zonder dat je direct wordt doorverwezen naar je mail-client?
    Zoiets dus?
    Code:
    [English]	=TEXT(B4;"@")
    
    [Dutch] 	=TEKST(B4;"@")
    Laatst gewijzigd door RedHead; 25-11-12 om 21:14. Reden: formule toegevoegd
    __________________
    Groet, Leo

    Zet je VBA-codes altijd tussen code-tags om je bericht leesbaar te houden.
    Gebruik daarvoor:
    • het knopje # in het berichtvenster dat je krijgt via de 'geavanceerd-knop' onderaan de reacties
    • het toetsenbord en direct intikken als HTML: [code] jouw code [/code]

  4. #3
    Geregistreerd
    Dec 2007
    Berichten
    4.433

    Standaard

    Ik zie net als Leo het nut er ook niet van in, maar ik hoef er niet mee werken.
    In F4 en doorvoeren.
    PHP Code:
    =ALS(B4="";"";ALS($H$2="Z -> A";AANTAL.ALS($B$4:$B$995;">"&B4)+1;SOMPRODUCT(($B$4:$B$995<>"")*($B$4:$B$995>0))-AANTAL.ALS($B$4:$B$995;">"&B4))) 
    mvg,
    Harry

    Wie met de duivel danst, moet het orkest betalen.

  5. #4
    Geregistreerd
    Nov 2012
    Berichten
    55

    Standaard

    Het idee achter mijn vraag is dat de ingegeven lijst toeneemt en de oude volgorde wens te behouden. Bij de automatisch sorteer functie (oplopend/aflopend) wordt hier geen rekening mee gehouden.
    Kan er iemand verklaren waarom het resultaat van de AANTAL.ALS functie verschillend is voor enerzijds met range ingave!$A$4:$A$995 en namen!$B$4:$B$995 ???

    Mijn 2de vraag is om het achterliggend adres (bij het overgaan van de muis komt dit te voorschijn) van een hyperlink weer te geven (voor de links van tabblad "ingave" kolom D).
    Laatst gewijzigd door PeTh; 26-11-12 om 19:38.

  6. #5
    Geregistreerd
    Nov 2006
    Locatie
    Delft
    Berichten
    7.361

    Standaard

    Dan ga je toch met een extra veld met record-nummers werken? Dus elk nieuw record geef je een opvolgend nummer. Dan kan je altijd de oude invoer-volgorde terugvinden (wat daar dan ook het nut weer van zou moeten zijn ). Zo heb je nog steeds geen formule of VBA-code nodig.
    __________________
    Groet, Leo

    Zet je VBA-codes altijd tussen code-tags om je bericht leesbaar te houden.
    Gebruik daarvoor:
    • het knopje # in het berichtvenster dat je krijgt via de 'geavanceerd-knop' onderaan de reacties
    • het toetsenbord en direct intikken als HTML: [code] jouw code [/code]

  7. #6
    Geregistreerd
    Nov 2012
    Berichten
    55

    Standaard

    Heeft er iemand nog een idee om van een lijst (wordt regelmatig aangevuld en dient behouden te blijven) automatisch m.b.v. dropdown menu oplopend of aflopend te sorteren? Alle suggesties zijn welkom.

  8. #7
    Geregistreerd
    Jan 2010
    Locatie
    De Haan Belgie
    Berichten
    100

    Standaard

    Misschien te eenvoudig .........
    Lijst kopie maken op nieuw blad (Blad2) en daar dan sorteren.
    Blad1 is origineel en Blad2 is gesorteerde weergave.

    Firmin

  9. #8
    Geregistreerd
    Nov 2008
    Berichten
    2.830

    Standaard

    De suggesties in #3 en #5 zijn dus niet goed?
    Doe eens handmatig:
    - selecteer B4:B23 en kopieer (ctrl-c)
    - selecteer K4 en plak als waarden (alt-ctrl-v w enter)
    - rechtsklik en kies Sorteren.
    Dit kunt je als macro opnemen, en een beetje (laten) bijwerken.
    - Frans
    pixcels.nl

  10. #9
    Geregistreerd
    Dec 2007
    Berichten
    4.433

    Standaard

    Citaat Oorspronkelijk geplaatst door xlcoach Bekijk Berichten
    De suggesties in #3 en #5 zijn dus niet goed?

    Citaat Oorspronkelijk geplaatst door PeTh Bekijk Berichten
    Alle suggesties zijn welkom.
    Tja, als er niet op geantwoord wordt, doe ik geen suggestie meer.
    mvg,
    Harry

    Wie met de duivel danst, moet het orkest betalen.

  11. #10
    Geregistreerd
    Nov 2012
    Berichten
    55

    Standaard

    Citaat Oorspronkelijk geplaatst door HSV Bekijk Berichten
    Tja, als er niet op geantwoord wordt, doe ik geen suggestie meer.
    @HSV
    Jouw oplossing wordt geapprecieerd maar je liet weten dat je het nut er niet van zie, dus vraag ik naar andere hun mening.
    Er is misschien voor mijn vraag een eenvoudige oplossing?

Gelijkwaardige Onderwerpen

  1. tabbladen alfabetisch op naam sorteren
    Door rit in forum Afgehandelde vragen
    Reacties: 11
    Laatste Bericht: 12-07-12, 08:41
  2. automatisch alfabetisch sorteren
    Door motordude in forum Afgehandelde vragen
    Reacties: 13
    Laatste Bericht: 20-01-12, 10:32
  3. Lijst sorteren
    Door Stuff in forum Afgehandelde vragen
    Reacties: 14
    Laatste Bericht: 05-02-10, 19:42
  4. Lijst kopieren en sorteren
    Door geertdaenen in forum Afgehandelde vragen
    Reacties: 9
    Laatste Bericht: 28-04-08, 09:56
  5. Lijst automatisch sorteren
    Door geertdaenen in forum Afgehandelde vragen
    Reacties: 7
    Laatste Bericht: 13-03-08, 21:22

Forum Rechten

  • Je mag geen nieuwe onderwerpen plaatsen
  • Je mag geen reacties plaatsen
  • Je mag geen bijlagen toevoegen
  • Je mag jouw berichten niet wijzigen
  •